Virtual Computer Lab (VLAB) overview

The Virtual Computer Lab (VLAB) provides PSU students access to a selection of academic software applications with their personal computer or mobile device, by visiting vlab.pdx.edu.

Note: Although this service is primarily for students, faculty also have access. We recommend that faculty and other PSU employees use RemoteApp for Enterprise Applications overview instead.

On this page

Start using the VLAB

From a web browser

  1. From a web browser, go to vlab.pdx.edu.
  2. On the Microsoft sign-in page, enter your @pdx.edu email address then select Next. You will be redirected to PSU's Single Sign-On page. 
  3. Enter your Odin account username and password. If prompted, authenticate your account with Duo Two-Factor Authentication (2FA).
  4. Select the Computer Lab icon to open a desktop session.
  5. On the Enter your credentials screen, enter your Odin account username and password, then select Submit.

From an application on your device

You can also access the VLAB using the Microsoft Remote Desktop application, which you can download and install on your computer or mobile device. The benefits of accessing the VLAB using the Remote Desktop application rather than through a web browser include:

  • Support for accessibility tools such as screen readers.
  • Multiple monitor support.
  • True fullscreen mode.
  • Improved touchscreen support.
  • Copy (Ctrl+C), Paste (Ctrl+V), and other keyboard hotkey support.
  • Improved application performance for some scenarios in the VLAB.
  • New features regularly added by Microsoft.

For directions on using this app on your computer or mobile device, see Install Microsoft Remote Desktop to access the VLAB.

Software in the VLAB

 Click for a list of VLAB software...

Application
Description
ArcGIS Desktop 10.7.1/ArcGIS Pro 2.xGeography mapping and imaging software
ArgusBusiness analytics software
Atlas.tiData visualization software
Audacity 2.0Free audio file editing software
ChemdrawChemical drawing tool
CLEA AstronomyPlanetary motion software
HSG ENVI 5.5GIS imaging software
Google ChromeCampus standard web browser
Kurzweil 3000ADA software for text-to-speech and scanning
Mathcad 15Engineering math software
Matlab 2019bProprietary math programming IDE
Microsoft Access 2016Database management system
Microsoft Office 2019(If possible, please download MS Office for free on your personal computer, instead of using it through VLAB. Learn more at Microsoft Office at PSU.)
Microsoft Project 2016Project management software
Minecraft Education EditionGame design and coding
MinitabStatistical modeling and analytics
MobaXTermSSH client
NetLogoSoftware modeling IDE
Notepad++Advanced text editor
Palisade Decision Tools 7.6Risk and decision analysis
pgAdmin 4.29PostgreSQL development platform
PuTTY 0.62SSH/Telnet client
QGISGIS imaging software
R-StatFree engineering math software
R-StudioGUI for R-Stat
SAS 9.4Statistical modeling and analytics
SPSS Statistics 26Statistical modeling and analytics
Stata 15Statistical modeling and analytics
TableauData visualization software
TerraGo ToolbarGeoPDF plug-in for Adobe Reader
Tinn-R 2.4.0.1Another GUI for R-Stat
Visual Studio CodeIDE
WinSCPFTP client

Notes: 

Save your work in the VLAB

We recommend that you use your PSU Google Drive to store files that you create in the VLAB. It’s a quick and easy way to access your files, and will provide you with more storage than other PSU network drives. 

Start using Google Drive for desktop in the VLAB

When you access the VLAB, you’ll be prompted to “Sign in to continue to Google Drive for desktop”. 

  1. In the Email or phone field, enter your @pdx.edu email address (not an alias, if you have one) then select Next.
  2. On the PSU Single Sign-On page, enter your Odin account credentials then select Sign In.
  3. If you are prompted, authenticate with Duo Two-Factor Authentication.

You will see a Welcome to Google Drive dialog screen, and a new Google Drive shortcut on the desktop. The Google Drive folder will provide you with access to the files in your PSU Google My Drive and Shared drives.

The next time you access the VLAB, you won’t need to sign in to your Google Drive, and the Google Drive shortcut will be available on the VLAB desktop.

Notes:

  • Files stored in your user profile (Desktop, My Documents, etc.) are not automatically saved to your H: drive or to any external storage. To make sure your files are backed up and accessible outside of the VLAB, upload any files that you need to Google Drive.
  • Any data that you save outside of your user profile can potentially be accessed by other VLAB users.
  • Currently, it is not an option to save to an external hard drive or USB stick.

Print from the VLAB

To print a file from the VLAB, you have two options. You can choose to print at a computer lab on campus, or print using your own printer.

Use a computer lab printer on campus

To print at an OIT-managed computer lab on campus, select a lab printer. You can do this while using the VLAB from any location. Then, when you are able to visit the computer lab on campus, use the Print release feature to print the file while you wait.

  1. Select File > Print (or type CTRL+P). The print dialog will pop up.
  2. Select the “lab_bw on cloudprint” or “Lab_Color on cloudprint” printer, then select Print.

Visit an OIT-managed computer lab on campus and use the Print release feature to print from your quota.

Use your own printer

To use your own printer, you will first need to save the file as a PDF to your local computer. From the document you want to print:

  1. Select File > Print (or type CTRL+P). The print dialog will pop up.
  2. The default printer should be "Remote Desktop Virtual Printer". If not, select it from the list of available printers then select Print.
  3. Follow the prompts to download your file as a PDF to your local computer. You can print the PDF file from a local printer, or from a web print location on campus

Sign out of the VLAB

It’s important to sign out when you are finished using the VLAB, so that other users can sign in. To sign out:

  1. Select your name from the User Account menu in the upper-right corner.
  2. Select Sign Out.

Notes:

  • After 15 minutes of inactivity, your screen will be locked within the VLAB.
  • Inactive and disconnected sessions will time out (and sign you out) after one hour.
  • You will be signed out after one hour if no input has been received within the VLAB.

Accessibility in the VLAB

By accessing the VLAB from an application on your device rather than through a web browser, you can use NVDA and Kurzweil 3000. Currently, the VLAB does not support JAWS and ZoomText.

To use accessibility tools such as a screen reader with the VLAB, see Install Microsoft Remote Desktop to access the VLAB.

Known issues or limitations

  • "No resource" error after signing in.
    This error happens when the servers are at capacity, so try signing in again later. Note: It’s important to sign out when you are finished using the VLAB, so that other users can sign in.
  • Sign-in issues with Chrome web browser.
    You may experience issues signing in to VLAB when using the Chrome web browser. You may see “...” and the sign in process will be stuck. If that happens, try refreshing the browser by clicking the Reload page icon in the upper-left corner. If you continue to have problems with Chrome, we recommend using Safari or Internet Explorer web browsers instead.
  • Ad-blockers may interfere with VLAB functionality.
    We recommend that you disable any web browser ad blockers while using the vlab.pdx.edu site.
  • Keyboard shortcuts for copying and pasting do not work.
    For now you will have to either: use the Edit menu at the top of the application window to select Copy and Paste, or right-click then select Copy or Paste from the contextual menu.
  • Slowness when using certain applications or accessing remote drives.
    When using the VLAB, you may notice that certain memory- or CPU-intensive applications perform more slowly than they do on a physical desktop computer. Also, H: and I: drives are not as fast as they are on a physical desktop computer.
  • Video conferencing tools and software are not recommended or supported in the VLAB.
    Software such as Zoom or Google Meet will have poor performance if used within a virtual lab session and should instead be used on your local system.
  • Aztec currently only allows one application to be run per session host.
    We are working with the vendor to resolve this limitation.
  • Minecraft game input only works when using the Desktop Client.
    We have filed a bug with the vendor to report that the game fails to work properly with the web client.

VLAB support

For support with the VLAB, contact the OIT Helpdesk.